InAppBrowser and SocialSharing plugins are not defined


I'm testing on iOS 10 and always have "InAppBrowser is not defined" error... Server is Version

And when trying to execute socialSharing action I have "SocialSharing: plugin is not present or not loaded" error in console. I'm testing on iOS10 and plugin is presented in resources scripts.

I will appreciate any help.

Thank you


Hello Mykola,

Just to make sure, you built a native application using OutSystems 10, you're using both these plugins, and while running the app on your phone you're getting these errors. Is that it?

If so, this may be related to an issue on that version, where the build didn't carry all the required plugins. Open the module for the plugin, go to the module properties, and edit the "Extensibility Configuration" (just add a newline in the end). Publish the plugin module and then refresh the references on your module. Once you publish your module, a new app should be generated and everything should be ok.

Best of luck,

Hi Rodrigo,

That fixed the problem - thank you very much.

I am getting the same error - tried this fix and still getting the error.

Hi Jason, 

Are you generating native application or using OutsytemsNow?

Hi Jason,

I had the same issue now it is working fine, if you are generating Native mobile app then please generate the app again after installing the plugin It will work fine. I was just publishing my app and refreshing after I generated the new build it works fine.


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.