Custom handlers - Silk UI Error

Custom handlers - Silk UI Error

  

After the message of incompatible Silk UI Web, I updated the module. Now I can not access any screen with Vanilla or Lisbon template.  Attached the screen with the error that I get.


Luck

Luciano Schiavo wrote:

After the message of incompatible Silk UI Web, I updated the module. Now I can not access any screen with Vanilla or Lisbon template.  Attached the screen with the error that I get.


Luck

Hello Luciano,

Do you have more than that eSpace consuming SILK UI Web? 

Kind Regards,

Miguel Vicente


Hi Miguel. 

Yeah. I did a test using Vanilla and when I tried to use Lisbon I received a message from forge that the Silk UI Web was not updated. So, I downloaded it and installed the Lisbon theme. However, since that, nothing worked well again.


Luck

Humm strange,

Can you publish a solution with all eSpaces? 

I'm guessing that you could have broken references.

Let's see what happens after you publish te solution.

Kind Regards,

Miguel Vicente

Hi Miguel,

   I didn´t understand what you mean wth can you publish a solution with all eSpaces... So, I am attaching the eSpace that is given the error message. 

I created a new application using London and it worked well, that way the problem is only the Silk UI Web.  When I downloaded the new it really changed the WebPaterns. It is different now appearing in red in the UI Flows.

After that the message: "The 'OnException Handler' property in Themes is being deprecated. Use an 'OnException' action of a UI Flow to handle exceptions globally to the module" appeared and even fixing that I have the same problem. 

The oml is attached. Maybe it can help you find out the error.

Thanks

Luck

Solution

Hey Luciano,

I mean in Service Center: 

Follow this steps:


Try this please,

Let me know if you have any problem.

Kind Regards,

Miguel Vicente

Solution

Well Miguel,

   I have good and bad news :) 

Good one: problems that appeared when I moved to version 10 vanished. However, this new error appeared when I use a screen to upload a file. It was working fine before: 'OutSystems2JSON' Action is incompatible with the 'ardoJSON' extension definition. Please update it.

Do you have some idea how to solve this ?


Luck

Hummm,

Niceee! 

Let's see the other one :)

Can you see if ardoJSON extension was plubished? 

Kind Regards,

Miguel Vicente 

I looked in factory-> Extensions and I didn' t find it. Should I download it from forge and use 1CP ?


Luck

Hummm strange,

Yes please! 


Done,

   but know there are 2 versions: 10.0.105.0 and 9.1.600.0.  What I do ?


Luck

The last one :) 

MV 


Good news. I followed the eSpaces and info through monitoring. I refreshed the eSpaces and both applications are working fine now.

Thanks so much for your help Miguel.

Have a good week :)


Luck

Nicee! 

You too!

Let me know if you need something in the future! 

Kind regards,

Miguel Vicente