Error installing an iPhone application created in Outsystems P10

Hi guys!

I'm in trouble with a Mobile App installation on my iPhone, through an app generated by OS P10. I built a mobile app in outsystems P10 Service Studio, and then I deploy this app first in Android. At this point ... so far so good!

But when I try to publish on Apple Native Platform, although the build process work well, I can not install the app on my iPhone. I'm getting the follwing message:

           Unable to Download App
HelloWorldApp could not be
Installed at this time
                  [Done] | [Retry]

I followed all the steps suggested in this link:

Important things:

   1) I enrolled an Apple Develope Account ($ 99.00 USD price) - not Enterprise.

   2) I created and register:

       a) An CSR and .P12 files (with OpenSSL for Windows);
       b) AppId & BundleID (AdHoc) - for my Application;
       c) Device UDID Record - for my iPhone 6S;
       d) And finally an App Provisioning Profile.

3) All the above have been used on Outsystems Native Platform Generate Screen (for Apple).

Has anyone here been through this?

Breno Nico

Hi Breno,

Allow me to thank you for providing such a detailed description of the issue.

I can understand that going through the "Apple certification process" is not so simple; let me try to help you on that.

Firstly, AdHoc Provisioning Profiles require the Device IDs to be registered in order to work on those devices. In case you have not registered them, you can find more information in this link.

I'll like to highlight that, after you register the devices you will need to create a new Provisioning Profile and regenerate the Mobile Application to propagate the changes made.

If you have already added the Devices to your P12 file, here you can find the most common for the error you are getting.

Let me now if this helped.


Rúben Capitão

Hi Rúben,

Reading your tips, I realized that my way to publish an app for iOS it's correct. I had made one video with the step by step. You can watch it at Am I doing something wrong?

I'm still having this problem.


Breno Nico

Hi ,

I am facing a similar problem. I was able to install the app the first time and it would get updated subsequently But after I uninstalled and tried to install again, I am getting the same error. I have tried installing another app with the same certificates and it is installing. Hence the issue is not with the certificates. 

Please Help

Keya Madhukar


First of all, nice video. You could make a tutorial out of it!

Now to your problem... The only reason why I've seen an app that was generated successfully failing to download is provisioning profile issues, such as the UDID registered in the profile being for a different phone, or the provisioning profile being using a certificate that has been revoked. In the video we can see the latter is not your case, so it's probably the former.