Why a rest doesn´t regard the default tenant ?

I am having problems because REST doesn´t regard multi-tenant. Someone knows how to enable multi-tenant to REST ?

Let me explain what I am trying to do...

I am using zTree and due to duplicate nodes I am loading some nodes asyncronous. According samples the way I have to reload the data is from some REST call available. It worked well until I realize the problem with multi-tenant.

SyntaxEditor Code Snippet

"'" + AddPersonalAreaToURLPath( "/PP/rest/UpdatezTree/getActualNodes") + "'"

I tried a workaround. I created an action at logic tab and used in the async only changing the name supplied in the REST call. Unfortunately nothing happened.

SyntaxEditor Code Snippet

"'" + AddPersonalAreaToURLPath( "/PP/zTreeLoadAsync") + "'"

Someone can help me ?


Hello Luciano,

can you take a look at this thread? It was the same question, but it took a turn to architecture. Still, I believe you'll find your answer there.

Hi Pedro,

   I saw this thread before posting mine. You will realize in my question (the workaround) that I tried a local action to replace the REST call, but it doesn't work.  But anyway, thank you for your suggestion.


I didn't get it. Please note that for the platform to understand from which tenant the date must be fetch, a user must be logged in, so, in your REST service you need to login with a user to be able to fetch data from that tenant. Did you tried something like that?

Hi Luciano,

I don't know if this helps but you can pass the TenantId as input in the REST Service. With that, before you do anything in the service you can use the system action TenantSwitch to execute the code on the tenant that you want.

Plácido Miranda