[ColorPicker] P10 Colorpicker Widget not showing up anymore

[ColorPicker] P10 Colorpicker Widget not showing up anymore

  
Forge Component
(3)
Published on 15 Aug by Pedro Cardoso
3 votes
Published on 15 Aug by Pedro Cardoso

It seems like with the upgrade of P10 the colorpicker widget is no longer working, the control does not show up on the page anymore, I've tested it with a brand new app and having it be the only thing on the page.

Hello, I use ColorPick in P10 normally, can you post your OML to take a look?

In fact, that demo is in my personal and it seems to be working pretty well...

That's interesting guys, thanks for the replies, hopefully it is just something I'm doing wrong. Here is my oml, which is about as simple as it gets. Let me know if I'm missing something simple haha.


Thanks again!

Omg, I figured it out, if you put the webblock before the input like this:

Then the color selector never shows up and you see the input, but if you put it after the input like this:

Then it works!

Damn what a noob bug! Let me fix that

Ok, it's fixed but we seem to have a problem with Forge that is now allowing me to upload the new version. I'll update you ASAP.

Woot! Thanks man!


Pedro Cardoso wrote:

Ok, it's fixed but we seem to have a problem with Forge that is now allowing me to upload the new version. I'll update you ASAP.



Pedro Cardoso wrote:

Ok, it's fixed but we seem to have a problem with Forge that is now allowing me to upload the new version. I'll update you ASAP.

Hi, Pedro.

Have you uploaded the new version to Forge? I had the same exact issue with Cody and I managed to solve it by using the same exact solution, again, found by Cody.

The problems are: first, where can I get the result of the color that I just picked? Second, it seems that I cannot use the options described in Spectrum GitHub webpage. Particularly this option right here http://bgrins.github.io/spectrum/#options-clickoutFiresChange

Every single time I added that option, the color picker widget dissappeared.


Extra info, I'm using this widget on top of my personal enviroment. I also included my .oml file here.

Ignasius Wijaya wrote:

Pedro Cardoso wrote:

Ok, it's fixed but we seem to have a problem with Forge that is now allowing me to upload the new version. I'll update you ASAP.

Hi, Pedro.

Have you uploaded the new version to Forge? I had the same exact issue with Cody and I managed to solve it by using the same exact solution, again, found by Cody.

The problems are: first, where can I get the result of the color that I just picked? Second, it seems that I cannot use the options described in Spectrum GitHub webpage. Particularly this option right here http://bgrins.github.io/spectrum/#options-clickoutFiresChange

Every single time I added that option, the color picker widget dissappeared.


Extra info, I'm using this widget on top of my personal enviroment. I also included my .oml file here.

Edit: My bad, I forgot to add ajax refresh to the label and also forgot to set the action destination when text input's content changed. It worked just fine after that.


Hello guys,


sorry for the (very) late reply. The new version is published!