Play Mp3 files

  

Hello,

How can i play a specific mp3 file when you are clicking a specific item in the sound list?

The mp3 file I shall use is in the resources.


Plz help


Hi Tobias,

You can use the HTML5 Goodies component from the Forge to play audio files. The component takes as an input parameter a URL that serves the audio file. In your case, you can create a screen in your application that receives an identifier as an input parameter and returns the respective resource using the "Download" element in the preparation.

I have tried, but am a beginner in outsystems and I did not really understand what you said I should do. Is there a possibility that you can explain it more detailed? ?? 


Plz

Hi Tobias,

Sorry for the delay. I've attached a simple example showing how to do it. If you need any further help, feel free to ask.

Aurelio Santos wrote:

Hi Tobias,

Sorry for the delay. I've attached a simple example showing how to do it. If you need any further help, feel free to ask.

Where is the example?  


Hi Tobias Loby,


you need to donwload the component (HTML5 Goodies) and see the exemple :)


Cheers,


Luís Pereira

Hi Tobias,

There seems to be an issue with attached files. Let me try again.

Edit: No luck. It looks like a bug in Outsystems' forum. I uploaded the sample to the Forge instead. Here's the link.

I have some problems. When i press the "play" button in the app, the audioplayer only are clickable in 1 sec and no sound is playing. I also get some errors in the filesystem dependencies.

Hi Tobias, sorry for the delayed reply.

What errors exactly are you getting? I downloaded the app from the Forge and was able to publish and run it without any problems.

I cant find the missing file.


https://youtu.be/o0O5REdp6lE

The audioplayer only are clickable in 1 sec and no sound is playing.

Tobias Loby wrote:

I cant find the missing file.


https://youtu.be/o0O5REdp6lE

The audioplayer only are clickable in 1 sec and no sound is playing.

You need to download the following:

https://www.outsystems.com/forge/component/68/filesystem/

Thx Justin Babel and of course Aurelio Santos for all the help. 


I just have one question agian: 

The audioplayer only are clickable in 1 sec and no sound is playing.

https://youtu.be/o0O5REdp6lE

Do you have an example OML I could take a quick look at?


Tobias,

That usually happens when the resource file is not found. Make sure that the resource's "Deploy Action" property is set to "Deploy to Target Directory", and that your download screen is correctly assigning the file name.

Now it works

Thanks for all the help