Integrate Outsystems with "Power BI Embedded"

Integrate Outsystems with "Power BI Embedded"

  

Hi,

We are trying to connect Power BI EMbedded (show graphs) into Outsystems.
Is there anyone out there who has done this before?

Thanks.

Hi Hans,

I did a component that allows you to embed Power BI reports in OutSystems apps. You can find it here (it works for web apps done in 10).

You can check the app running here.

Cheers,
R

Super, I will look at it tomorrow. Thanks!

Hi Rodrigo,

The sample works also in my application (still a poc). Perfect.

What I was wondering about is what actions needs to be done to call a reportID which we ourselves have made?

I guess at least somewhere another workspace collection and workspace id must be specified, maybe more. Where can that be done?

(Maybe it is puzzeling me because I can't see the boundary between what parts are general available and which did you build specific for the component.)

Thanks.

Hello Hans,

I haven't tried embedding one of my own reports with this code, but I found this article that should explain what you need to do. Haven't tried it though...

Good luck!
R

Hi Rodrigo,

It seems this component is only available in the Java stack. Can you confirm?

Thanks.

Solution

Status from my side:

So the compoment worked in my personal outsystems cloud (10), but my customer is still on 9 (.net) So i could not use the component. I decided to build the solution in 9, based on the solution in 10. Copy/paste didn't work so I build most of it by hand.

This worked perfectly. Only I was still using the demo graph of the component. 

What was needed for using our own graph was to make our own version of the rest API GetReport (other Base URL basically). The API returns the same variables (AccessToken and EmbedURL). So now we can finally see our own Power BI Graph.

Thanks for sharing your solution, it helped a lot!


Solution

Leen Rietveld wrote:

Hi Rodrigo,

It seems this component is only available in the Java stack. Can you confirm?

Thanks.

Hello Leen,

The component works on all stacks. This message appears because I forgot so set the supported stacks when I uploaded the component... :) It is fixed now.

Cheers,
R

Hi, Rodrigo !

Do you have any predictions about the updating of your component by returning the parameters of your site in azure according to the url below?

https://microsoft.github.io/PowerBI-JavaScript/demo/v2-demo/index.html

I think many users would like this update!

Thank you very much !

Angelo Frizzo Junior
Web developer
Marist Group