Starting this morning, I've been unable to publish to my personal environment. The 1 Click Publish operation always gets stuck on step 3 ("Deploying") without giving any error messages.

Environment health shows the following:

What could be causing this?

Dear Aurelio,

Can you please check if the 1 Click Publish operation keeps getting stuck on step 3 ("Deploying") without giving any error messages?

In this kind of issues, please contact success@outsystems.com 

Best Regards,

Mário Pereira

Hi Mário,

That's exactly what was going on. However, it seems like the problem solved itself. Everything seems to be back to normal now. Thanks anyway!


I'm having the same issue since yesterday afternoon. I waited to see if the problem would self-heal over night but it still persists and I cannot publish anymore.

Can you please unlock this?

Thank you,


I've unmarked this post as solved, so that your problem gets more visibility.

Best regards.

Hello Snooze and Aurelio, 

Can you please please check if the issue still happening?

By the way, for issues with personals, please contact success@outsystems.com.

Happy New Year! :)

Hi Mário,

Not on my side. Everything's working fine here.

Hello Mario,

I still cannot publish - and environment health is still warning about deploy service. I emailed success@outsystems.com first thing today. 

Thank you