The IP rights of your applications could not be granted!

Hi all,

I built an app in my personal environment, tried to load it into our on-premis enterprise environment, and got an intellectual Property erro. I went to the IPP page and requested validation.

What I received was the rejection underneath. I don't get it ... it's my personal environment, my enterprise environment, so why shouldn't I be able to port my app? 

But more important .... is there a way to get the job done without having to do it all over again>?

The IP rights of your applications could not be granted!


 The Intellectual Property rights of the application(s) you requested could not be granted due to a rule that prevents uploading solutions from a Personal to an Enterprise environment.

not sure if it still works, but a workaround is, publish it to the forge, then it will be ip-free.

but ther are clearly disadvantages to it, so I would not recommend it.

best way is to contact outsystems directly (via support)

Yeah, maybe I'll contact support. Thanks for replying J.

By the way, we tried to port an app from one personal environment to another personal environment ... and same issue. The IPP Rights Validation was not granted.


Just to let you know ... I contacted Support, explained the situation (why we developed an app in a personal environment and now would like to port it to our enterprise environment), and was granted to port the app.

Problem solved :-)