[Silk UI Mobile] expression text disappears when scrolling a list within a section expandable

[Silk UI Mobile] expression text disappears when scrolling a list within a section expandable

  
Forge Component
(13)
Published on 4 Aug (2 weeks ago) by OutSystems R&D
13 votes
Published on 4 Aug (2 weeks ago) by OutSystems R&D

On my mobile app dashboard I have a section expandable.  Within the section expandable is a list.  Within the list items is an expression and a container with a few buttons.  Odd behaviour is that when I load the app, click to expand the section expandable and then scroll the list, the expression seems to white out (no longer visible) in the middle 3/5ths of the phone screen.  the buttons are always there and visible, but the expression text seems to go away.  Any ideas?

Hi Jason, which device are you using to test the app?
I've tried to create an espace with that structure but couldn't reproduce the problem, using an iPhone 6, iOS 10.

Dinis Carvalho wrote:

Hi Jason, which device are you using to test the app?
I've tried to create an espace with that structure but couldn't reproduce the problem, using an iPhone 6, iOS 10.

I was using an iphone SE.  My developer had the same issue on his iphone, don't know what model.  However, see my above comment that after we upgraded our server last night (not silk mobile, just the server) the problem appears to have gone away.


Hi so at which version you upgraded to?

I'm having appearance issue with Section Expandable too please look at https://www.outsystems.com/forums/discussion/21953/bugs-section-expandables-issue-with-appearance/

Eric,

We upgraded to whatever the most up to date version of the server platform there was at that time.  We typically give a release a few weeks to stabilize then move up.  Ours was not what you are seeing, ours was if you scrolled the screen the text would disappear in the center.  What I would do is remove everything and just have a container with the text, then put the section expandable in it, then add in the reactive columns.  Do that until you find what layer is causing the view issues.