[CameraPreview Plugin] Error: CameraPreview is not defined

[CameraPreview Plugin] Error: CameraPreview is not defined

  
Forge Component
(3)
Published on 17 Feb by Rodrigo Coutinho
3 votes
Published on 17 Feb by Rodrigo Coutinho

Hi,

i tried to use the CameraPreview Plugin, but in Example-App and in my own App i get the error "CameraPreview is not defined" after starting "StartCameraPreview". Any ideas what goes wrong?

I tried on IPad and Outsystems platform 10.0.210.0


Jens

Hello Jens,

I just tested the plugin using the sample app and everything appears to be ok...

Just to be sure, did you create a native application and installed it on your device in order to use the plugin? You need to create a native app for the plugin to work...

If you did create the native app, and it still doesn't work, might be an issue plugins had in some versions of the platform... To fix, open the CameraPreviewPlugin module, go to the module properties and open the Extensibility Configurations. Add an enter in the end of the JSON. Next, open the module that is using the plugin, refresh the references and publish the module again. A new version of the native app will automatically be built. Install on your device and everything should work.

Best of luck!
R

Hi R,

thanks for your answer. I published my App with outsystems, but until now not as an native app. If this is the reason, how can i test it, without creating a native app? Any chance?

Sorry, you'll need to create the native app in order to test the plugin.... Part of the plugin is native code...