[Exchange Web Services] Help! Problems with ServiceUrl

Forge Component
Published on 2016-10-25 by Fernando Branco
2 votes
Published on 2016-10-25 by Fernando Branco

Platform Version: Outsystems 10.0.302.0

Hello! Downloaded and installed this version of exchange. We seem to be having problems with the URL. It's sending emails, but it doesn't seem to be sending emails to internal network outlook emails. Is there a particular ServiceUrl? We tried the one provided by outlook with an asmx format. When it reaches the CreateAppointment action, the next error comes up:

"The request failed. The underlying connection was closed: An unexpected error occurred on a send."

Sorry to bump this up, but we still need some aid. A more detailed account provided below:

We'de been working with two extensions. 

The first one was Exchange Services Integration and it worked for a while, sending the emails we required and creating the appointments. The app sends an email to the client and to the employee that is to work with the client's case. The employee is supposed to get a Meeting Request - thus why we're using Exchange. The email to the client is sent but, the one to the employee isn't. When debugging, the CreateAppointment action shows us an error in the Domain parameter: "The Autodiscover service couldn't be located."

Now, we tried this extension provided here as suggested by Outsystems support. Instead of Domain propery it has a ServiceUrl property, which seems to work about the same. The errors on this one though weren't so much about Autodiscovery - and no, no email to the employee was sent either. We tried a few domains and urls that actually worked when verified against a browser. Depending on the url provided the errors are more detailed:
- If the url provided ends with .wsdl - "The request failed. The underlying connection was closed: An unexpected error occurred on a send."
- If the url provided ends with .asmx (the same one was used) - "The request failed. Unable to connect to the remote server"

Any help to figure this out would be highly appreciated! Thank you.

I'm getting this now as well...

Any updates?