Error Consume REST API OutSystems 10

Error Consume REST API OutSystems 10

  

Hi OutSystems,

We tried to consume REST API from our internal back end service. But we have got this error 

And from our service center monitoring we got the error log. 

HTTP response '503: Service Unavailable' when communicating with http://127.0.0.1/ServiceCenter/ServiceStudio

Any suggestions for this issue ?

Thank You

Hi

There seems to be some communication issue between the Platform Server and Service Studio. The REST call is done in the server, and it seems unable to reply back to Service Studio.

If you try to use REST with a different address (ex: www.google.com) does it work?

João Amorim wrote:

Hi

There seems to be some communication issue between the Platform Server and Service Studio. The REST call is done in the server, and it seems unable to reply back to Service Studio.

If you try to use REST with a different address (ex: www.google.com) does it work?

Hi Jose

Sorry for missing text :D

Hmm, our environment can't connect to internet and after we tried to access local URL, still same response. And also we can confirmation that the URL can access via postman. 


Can you create the method manually (pasting the expected JSON in the Body -> Response area) and test it in runtime (create a simple app that calls the method) to see if it works?

Solution

João Amorim wrote:

Can you create the method manually (pasting the expected JSON in the Body -> Response area) and test it in runtime (create a simple app that calls the method) to see if it works?

Hello this issue currently done. It's happen because our environment using proxy to connect internet. Our mistake was not ignored localhost and internal IP.


Solution