[Silk UI Web] AmPmTextToTime works except from 12:00PM to 12:59PM

Forge Component
Published on 22 Oct by OutSystems R&D
94 votes
Published on 22 Oct by OutSystems R&D

For some reason when I run the AmPmTextToTime Method on a time between "12:00PM" and "12:59PM" (formatted as such) it comes back with 00:00:00 as the time.

For Instance :


Will output "00:00"



Will correctly output "13:03"

Also It looks like 12:00AM Gives the time as 12:00 instead of 00:00

Figured it out, there was no way of adapting for 12 oclock times which behave differently, so 12:00am would stay at 12 hours (making it 12:00PM) and 12:00PM would become 24 hours, which would then overshoot and break the time creation.

Here is how it was:

I fixed it by adding

I am not going to mark this as solved because I am hoping that this can get fixed in the platform. Until then I will use my own local version.

I'm having the same issue, it's obviously a bug.  Please fix this ASAP. Please note that in the US when using AM/PM most people will be using 12:00 format instead of 00:00 format.


Hi guys,

Sorry for the late reply, just an update to let you know that this issue was added to our backlog, it should be fixed in the next release of Silk UI.