BUG FOUND: critical error, serviceStudio - 'Unknown' Data Type in 'List'

Required Property Value Unknown 'Unknown' Data Type in 'List' Output Parameter.

Outsystems Platform 10.1.303.0 (.NET + MySQL)

How to reproduce issue

1) Create an extension, and import a MySQL table

2) Create an eSpace with an action with one input and one list output parameter

3) Assign the list output parameter with an entity (created in step #1)

note\: This issue does not occur when referencing the platform SQL Server database.

Workaround: currently no work around?

Hi Robert,

Can you send us an eSpace and an extension where the error occurs? 


Refer to Case [#1626153] (the first account.oml submitted contains this bug).

The datatype key inside the eSpace was out of sync the only way to fix this is to change the data type from "list" to "text"then back from "text" to "list" this will update the key in the eSpace file. Then it will solve the "unknown" datatype problem.

This is an extremely difficult bug to reproduce because you have to get your eSpace out of sync and that's hard to do However I came across this issue twice, spent a few days trying to solve it, and finally found the solution (the bug still exist in outsystems platform 10.1.303.0).

Same error over here. Same work around attempt. But same error again.

I'm using Development Environment 9.1.608.0, and Platform Server 9.1.300.2

And the error seems to be related to a 'List of <Object> Identifier', not espace being out of sync. It works if I use 'List of Integer'