Popup feedback message problem silkui

  

Hi,

I'm having a problem with Feedback Message mechanism and Popups while using SilkUi patterns. 

When calling the Feedback Message action from any popup the feedback message will always appear behind the popup, on the main parent, taking the chance to click it.

By my findings I can see that the popup html also as a feedback message web-block included, but I don't see a reason why is not being use on this situation.

Now I know that one workaround is to disable the z-index:9 on the theme, but I would really much prefer to make use the in-build mechanism inside the popup. For example when outsystems detects there is a problem with a client script inside a pop-up, the message feedback will automatically appear inside the pop-up and not in the main page.

Is there any way to accomplish this for any message that I might throw?

extra: Attached an OML with example of the problem using Lisbon Theme.

Thanks and Regards,

André


Solution

Hi André,

The only workaround I see is the same you did using CSS, while we can evaluate the change in Silk UI.

Doing the same test using London theme has the same results, it's the "main" feedback message that gets triggered, but has a higher z-index.

Solution

Hi Dinis,

Thanks for your reply. I will be waiting for those changes on Silk. For sure those would much appreciated by me and other programmers on this forum.

Regards,

André

Hi 

We are also facing the same issue. The feedback message is getting displayed on the parent page instead of displaying on the pop-up.

We are using dublin theme.

Keep us informed if there is any update on this behavior.

Thanks

Ravi


Just an head's up regarding this issue.

The feedback message of the main page is always the one triggered, for all templates, whether they are Silk not not. If we look at the London Theme, it's the same, but since it has a higher z-index, it's displayed on top of the popup overlay.

We'll add this fix for Silk templates in future versions. Thanks for the feedback guys!

Hi André,

I'm having the same issue. Can you give me more details about your workaround?

Thank you,

Roberto

ROBERTO CAMPOS wrote:

Hi André,

I'm having the same issue. Can you give me more details about your workaround?

Thank you,

Roberto

Hi Roberto,

Please refer to the answer given by Dinis Carvalho.

For now what you can do is disable the z-index:9 on the theme for the feedback message, which will force it to always appear in front of any element draw in the screen.

Regards,

André


Hi André,

Thanks for your attention. I tried to do the Dini's recommendation. The problem is myself, because I'm not a CSS programmer. I search and found a z-index:9  in the script's theme. Then I put it in comments  as bellow:

SyntaxEditor Code Snippet

/* This margin-top:0px is for all pages without .Page in layout **************************/
div.Feedback_Message_Wrapper {
    left: 0;
    margin-top: 0;
    /*z-index: 9;*/
}

How I don't get update the "Doublin Theme" tab in editor, I added this code in my application tab. But this not worked. Can you help me with the correct procedure to do ?

Thanks,

Roberto