[Html2PdfConverter] working with html to PDF convertter

[Html2PdfConverter] working with html to PDF convertter

  
Forge Component
(42)
Published on 23 Jun by Guilherme Pereira
42 votes
Published on 23 Jun by Guilherme Pereira

I download the Html2PdfConverter  extension, first I use the Integration Studio but I have an output in the compilation:

The message is about the ToolsVersion because the extension use 12 and maybe the extension need the 4. But I can continue publishing, after all, the process I get this message:


But the message before the publish shows a warning because the consumer module is outdated.

Then I use read installation notes and try to upload the exec file but got an error message:


And finally when I am using the extension in  my app I got this:

But don't know what I did wrong in the process. Because the administration tool didnt upload the fileI need to use this extension.


thanks,

Tomás



Hi Tomás,

I'm a bit confused. You are speaking about .NET and are trying to upload .exe files. But the URL in the image you added makes me think that you are using the Java version of the OutSystems platform, which in a PaaS setup is running on a Linux operating system.

If i'm not mistaking, what you should do is to download the Linux version of the wkhtmltox binaries. Then in the administration screen of html2pdf set the Home Folder (at the bottom of the page). The path you need to set depends on the platform version and settings, but my best bet for your situation would be something like "/opt/wildfly-8.2.0.Final/standalone/deployments/".

I hope this information makes sence.

Regards, Fons

Hi Fons, 

     Yes, I am working with Java version of Outsystems platform. I download the latest version of Html2PdfConverter but first in the Integration Studio I got the message trying to compile in both, Java and .Net. Thanks for your comments, I will try with to make it work.


Thanks,

Tomás

Hi All, 


    I tried with all the possible linux binaries but without success. I still have the same mistake. I notice that error message always show "binaries" and the directory is "bin". 

I changed "bin" to "binaries" but the error still the same.



Thanks,

Tomás