App won't update after publishing

I am getting the following message on OutSystems Now and on mobile device when my app is starting: 

“An error occurred while trying to update the app. If you want to retry the update, restart the app.  If the problem persists you can reinstall,but all local data will be lost.”

I don't know what is causing it or what to do about it.  I tried re-publishing, but that doesn't help.  I can't move ahead with changes.  Any ideas?  Thanks!

  -- JA

Hi JM,

Are there any related errors in Service Center?

Try uninstalling the app and install it again and see if the problem persists.

João Neves wrote:

Hi JM,

Are there any related errors in Service Center?

Try uninstalling the app and install it again and see if the problem persists.

I tried uninstalling and reinstalling on the mobile device.  When I try running on the device it briefly flashes the login screen and then gives me a message that "There was an error processing your request." and a single option to "RELOAD".  Clicking RELOAD causes it to try again and then come back to the same error screen.


Attached is a copy of the error log.  Ideas about how to get past this??  Thanks!


Same issue here, 2 years later no answer for that...

Hi JM Ackerman,

Based on the error logs you shared there's an error for sqllite-3:

Which means; As of you have made some new implementation, You need to do a refresh of the dependencies for the all the modules of Mobile Application. This way you can fix the error.

On a Highlevel the issue is Mobile app expecting some entities which are not yet referenced by this module & this they are not synced i.e updated in the mobile app on device n thus the error occurred.


Hope it helps.

Assif 



JT wrote:

Same issue here, 2 years later no answer for that...

Hi JT,

There's always a solution provided by folks here or in the end by Outsstem Support.

You can share your error log & Issue , I hope there's always something we are doing a mistake & it can be resolved by correct approach.



assif_tiger wrote:

JT wrote:

Same issue here, 2 years later no answer for that...

Hi JT,

There's always a solution provided by folks here or in the end by Outsstem Support.

You can share your error log & Issue , I hope there's always something we are doing a mistake & it can be resolved by correct approach.



Hello Assif, as you can see this thread is over 2 years old, and never had an answer before today.

I know you help a lot, you are actually one the few who has been helping with my issues, but the fact is I most of my questions remained either without a solution or I found the solution (or a workaround). 

At this momento I have 4 or more questions without any anwers or none thats of any help.

I know you guys try your best to help, but I do feel very unsupported everytime i need help.


JT wrote:

assif_tiger wrote:

JT wrote:

Same issue here, 2 years later no answer for that...

Hi JT,

There's always a solution provided by folks here or in the end by Outsstem Support.

You can share your error log & Issue , I hope there's always something we are doing a mistake & it can be resolved by correct approach.



Hello Assif, as you can see this thread is over 2 years old, and never had an answer before today.

I know you help a lot, you are actually one the few who has been helping with my issues, but the fact is I most of my questions remained either without a solution or I found the solution (or a workaround). 

At this momento I have 4 or more questions without any anwers or none thats of any help.

I know you guys try your best to help, but I do feel very unsupported everytime i need help.


Yup I do agree, there are some questions left UnAnswered & this also a case with mine questions which are not answered yet but at the same time I didn't communicate with OS support as it;'s my personal account, not enterprise.

 But let's try to share the issues more & if you get the solution always try to update the same so that further it will help folks like me If we get on the same page.

let's not discuss further more here as it is a off discussion, you can send me the post links & will try to check :)

Thank You & I too appreciate your work & contribution as a member here like me n other folks.

Kindly