Debug over eSpaces not working. Select entry eSpace list is empty.

Debug over eSpaces not working. Select entry eSpace list is empty.

  

I am trying to debug over 2 eSpaces. This is not working, I cannot get it to break at a breakpoint in an action of the main eSpace.

I have a main eSpace where user logs in and everything starts there, then it kicks off a page in a 2nd eSpace via a URL - I use a URL so that I do not get circular references because the second eSpace references the main eSpace already to get shared elements, actions, themes etc from the main eSpace, so the main eSpace cannot reference the 2nd one so I open the pages via URL so I need not add a reference into the main eSpace to the 2nd one.

I found this as instructions to debug over multiple eSpaces, but when I get to step 4. in the 2nd eSpace then the list is empty, well it is empty on both eSpaces, the only option is "(this eSpace)". At least the second eSpace should contain the main eSpace as it references it, or not?

1. Set a breakpoint in the producer espace. 
2. Tell the producer espace to "Debug in Public Area" 
3. Tell the consumer espace to "Debug in Public Area" 
4. Set the Entry eSpace, on consumer, by going to Debugger -> Select Entry eSpace 
5. Do actions that should cause the breakpoint to be hit.

Hi,

When an espace doesn't appear on "Select Entry Espace" list, I open that espace and run on personal area. Then close and open the espace, now should appear on "Select Entry Espace" list.

Audit is workaround when debug isn't working.

Hi Elize,

What exactly are you trying to debug? An action that is called on the page that you are navigating to or on the main espace? If you are only navigating from espace to espace, and the actions you are trying to debug are within that espace, there is no need to set an entry espace, as the entry espace for both of the espaces in your situation would be itself.

Let me know,

Justin

er, the instruction are a bit wrong.


- open both espaces.

- have them up2date as possible (so no outdated references)

- the producer-espace, you select the entry-espace (this works only when it actually has references in the consumer espace)

- start debugging the producer-esp0ac, it should say "debug <consumer-espace>



Hi Elize,

Usually when this happens, it's because the consumer eSpace is outdated.

However, since you are using external url to access the 2nd eSpace, I believe that you don't need to set "the entry eSpace", cause the 2nd its became the first entry (through external url).

Let us know if our understanding is wrong about your problem.

Cumps,
Breno

Yes Breno,

You are correct , in case of external url you dont refer then directly through add references and thus you don't need to set the entry espace .

you can also try one thing just to test , copy the url with parameter if any and paste the complete url  in browser directly. don't forget to put the break point in preparation of the page. Hit enter in teh url bar of browser and see if the debugging works.


Regards

-PJ-


Nelson Inácio wrote:

Hi,

When an espace doesn't appear on "Select Entry Espace" list, I open that espace and run on personal area. Then close and open the espace, now should appear on "Select Entry Espace" list.

Audit is workaround when debug isn't working.

Waking up an old thread. 

This appeared to be part of the solution to my problem. 

The other thing I did was republish the forge component locally as it was not originally published with the same version of Service Studio. Unfortunately I performed both steps without testing in between, so cannot definitively say which one solved the problem.

FYI My scenario:

My_UI_ModuleA, consumes My_Lib_ModuleB, consumes Forge_ModuleC.

I was trying to step through Forge_moduleC and could only set the entry module as Lib_ModuleB which has no UI.

After following  Nelson's advice as well as publishing Forge_ModuleC locally, I was able to select My_UI_ModuleA as entry point when debugging Forge_ModuleC.