I'm getting this error after we upgraded to P10 on one of my projects:

Unexpected Data Type

'OrganizationContracts Identifier' data type expected instead of 'Integer'.

I believe because of the new paltform's stricter rules this will cause a query to fail?

It worked before the upgrade.


Just to add ...

Im using this function:


To provide an input parameter to an action. The action does not return any results. I suspect it might be because of the type mismatch.

Hi Jean-Pierre,

Have you tried using the IntegerToIdentifier(Integer) function? I believe they started using long integers as identifiers in P9 Bali. So this might be the reason you are getting the error.


Thanks for the reply. Although I'm receiveing warning messages. I think that this might not be the problem. I've noticed a pattern that none of my onchange events actually fire. Debugging a part of the system works, but then as soon as the onchange fires it never gets to the break point as if the function is not called at all.