I have a very weird problem regarding the personal environment. I am able to login to my outsystems account, but not to my personal environment. It's up and running (the color is green) but every time i try to log in via the application, it says password invalid, after to many tries, it blocks me out for an hour. What's even weirder is that i'm not able to change my password 'the normal way'. Every time i try to change my password in my profile, it also says password invalid. But I am able to login to the website using the same password. I have no idea what to do now, because I am not able to start or find any apps now at the moment. Anyone have any ideas?

Hi Inne,

I have send an email to OutSystems support for this issue yesterday. I'm waiting on feedback.

When you say you try to log in via the application, is it an application you created?

Your OutSystems account may not always be added as a User in for your application. If you go to the Users application in your environment <enviornment>.outsystemscloud.com/Users you will see the users and the roles that those users have. If your user is not there that might be your problem if it is there another thing that I have seen is that you might be pointing your application to a different User espace. So in your application properties you can select the User module you want to use, if it's set to the Current espace that could be the problem. So if you change that to be the Users module you can use any of the logins that you saw when you entered the Users application.

Hope this information is helpful.

Andres Moreno

I have this exact problem, currently waiting for Outsystems to get back to me with a solution. Also, none of them seem to grasp that if we can't log in to the Development Environment, we can't do ANYTHING with it i.e. the comment above! 

Edit: if you get a solution can you post it on here? Ta.


No it's not related to the users espace.

Inne can logon to www.outsystems.com but when she tries to change her password via the profile page, it indicates the current password is incorrect. Which is odd as she just used it to login to the outsystems site. Same issue for the connection to service studio.


I agree with you. I've had the same logon problem with the account I just recently created. As I was trying to connect to environment, it always prompts me with the communication error: "There was an error contacting 'account.outsystemscloud.com': Invalid username/password."

So I decided to head over to my profile page to change my current password with a new one but it prompts me with "Current password is invalid" error.

Any feedback would be appreciated. Many thanks.


This was solved by OutSystems support. There was a sync error on their side. If you still have the issue, then it means they only solved it for Inne.

I'd suggest you contact Support (support@outsystems.com) and say you have the same issues as described in support case #2000144. That should point them in the right direction to solve your problem.


Thank you @Kurt

I was able to access it after changing my password through Password Recover.

It's good to know that we have quick responses towards solving problems such as these.

Good morning,

I'm currently having the same problem. I updated my password, i can login to the Outsystems web site, i can loging to users, my personal environment is good to go with green light and i keep getting an invalid password error.

I even created a new user and i'm always getting the same error. Any ideas?

The problem is accessing your PE via service studio, right? There you only have 1 user you can use, the one you used to register you environment. So I don't see where you created a new user.

Hi Kurt,

I created the user to try to login to the PE since i can't login with the normal user. Like i said before, i reset the password, try to login and keep getting wrong password.

How did you create that user? From what I know, you cannot create multiple developer accounts on your PE. Only business users (via the users espace) is possible.

Hi Kurt,

Must have been a temporary glitch since i'm able to login again with the normal user.

I created him only to try and test the login with another user at the time, and it was created through Users espace. I found it strange since i could login everywhere but not on SS.

Thanks for the help.