Tree focus issue after adding local variable

This one is pretty hard to nail down 100%, and I'm sorry for that, but perhaps some of my observations will help?

When you add a new local variable, it lets you edit the name right in the tree:

What I've found on a fairly regular basis is that if I start typing, all of a sudden, I'm jumping all over the tree instead of editing the name.

(What am I doing down here?)

One thing I've noticed is that it's not necessarily related to what I'm typing. This can be triggered (when it's going to happen) by just pressing the Shift key (as I often do to capitalize the first letter of the identifier, of course). In my above example, I just pressed Shift and it jumped down to Layout, and I wasn't even on Layout previously.

Wild conjecture: maybe there's a leftover tree search handler on key up or key down that's not respecting the edit mode sometimes?

This happened in OutSystems 9, too, so it isn't new.

If I can characterize the issue further, I will :)

-- Ritchie

Hi Ritchie,

I tried to reproduce the behavior but wasn't able to. Could you please submit feedback in Service Studio so we can try to understand what's happening.

Thank you!

Henrique Henriques

I got it to happen right as I came in this morning, but once I started trying to replicate it after that point, I was unable to, so I'm not sure what the triggering condition is.

A little more detail is that what happens is you do something to add, say, a local variable to the tree and, under whatever those particular conditions are, if you start typing, it goes into "search mode" and moves you through the tree as usual, but it leaves the edit box sitting in the tree.

If you then click in the edit box, it's still not "ready" somehow, and pressing any key (including Shift) will jump you back to where the search last took you.

I've tried numerous focus tricks (switching tabs, views, minimize/maximize) to see if that would cause it, but so far, no dice. It happens seldom enough - maybe five or six times a day, that it's maddening to try to find a pattern in it, but it seems definitive when it happens; it doesn't seem like it's a threading hiccup.

I'll keep trying to remember what it is I just did when it happens. It's just so easy to gloss over small UI glitches when they happen and just keep going.

-- Ritchie

Hi again Ritchie,

I spent some time trying to reproduce it again and I see what you mean about it being maddening :)

Have you submitted feedback about it? The information on the report can help us understand what's happening.


Henrique Henriques

I'll do that next time it happens, preferably while the in-place editor is still up.

I've sent some feedback, though I'm not sure what they'll be able to tell from the screenshot. It's happened another few times today already.

The only one other observation I've found is that when you go Add Local Variable and it pops up with that in-tree edit box, if you can't see the cursor flashing inside that edit box, then this issue will happen. It's definitely not when you start typing, because as soon as I saw the edit box pop up without a cursor, I had a suspicion, and I waited a good long time before typing any letters.

Hi Ritchie,

Thanks for submitting feedback! We'll look into it and try to understand what's happening.


Henrique Henriques