[Field Services Mobile] Field Services App doesn't work with Oracle Database

[Field Services Mobile] Field Services App doesn't work with Oracle Database

  
Forge Component
(5)
Published on 10 May by OutSystems Labs
5 votes
Published on 10 May by OutSystems Labs

Hi,


It looks like this app isn't compatible with an Oracle Database. When installing the application I get this error:

Upgrading: No need to upgrade Application.
Uploading: Uploading Application.
Uploading eSpace: Uploading eSpace FieldServicesMobile.
Uploading eSpace: Uploading eSpace FieldServicesMobileAssets.
Uploading eSpace: Uploading eSpace FieldServicesMobileSampleData.
Creating Application: Creating Application 'Field_Services_Mobile'.
Verifying: Verifying the Application consistency and permission settings.
Upgrading Modules: Upgrading and refreshing modules of 'Field_Services_Mobile'.
Impact Analysis: Performing Impact Analysis of 'Field_Services_Mobile'.
Preparing Extensions: Preparing extensions of 'Field_Services_Mobile'.
Preparing Database: Preparing database of 'Field_Services_Mobile'.
Preparing Database: Preparing database of module 'FieldServicesMobile'.
Invalid Attribute: 'Alerts.Timestamp' is an invalid attribute name in Oracle.
Invalid Attribute: 'LocalDashboardTimeline.Timestamp' is an invalid attribute name in Oracle.
Invalid Attribute: 'LocalAlerts.Timestamp' is an invalid attribute name in Oracle.
(Error) Publishing Application: Error publishing Application Dependencies
Preparing Deploy: Preparing deploy of 'Field_Services_Mobile'.
(Warning) Execution Plan Suspended: Deployment process was suspended due to an error.
Execution Plan Suspended: Deployment process was suspended due to an error.


Which looks like some entity attributes (Alert, LocalDashboardTimeline and LocalAlerts) have names (Timestamp) that aren't supported in Oracle.

Solution

Hello Martijn,

We already know that and it's fixed but we haven't released that version yet.

What you mention is exactly the issue. I downloaded the application from Forge and changed those fields.

You can download the attached Field services module and install it in your environment.

Cheers,

Magda Pereira

Solution

Hi Magda,


Good to hear that you already fixed it. Looking forward to the new version of this demo app.


Kind Regards,

Martijn Habraken