Data not displaying properly

Data not displaying properly

  

I have a list with a Block inside each ListItem, to display records that match the main element in the ListItem. Everything is there but only uses half of the available screen. The horizontal bar that separates the records inside the bock shows that only goes half way. I went through every element and set them to "fill Parent" but still uses only half


Hi, check the Container surrounding the block or list.

Set width to fill parent.

If there is no container, try to enclose the block/list in container, then set width to fill parent.

Hope it helps...

Thanks for the response. I tried, but did not work. Any other ideas?

Hi Gonzalo Labarca,

have you tried changing the property of list widget Line Separator to None? 

Hope this help.

Regards,

Manish Jawla

Thanks Manish. Where would I find that property ? I don't see it here.

Gonzalo

Hi Gonzalo,

Please find the attachment for solution because u have to simply align your content under content box.

It might be possible you have placed one content in container and another without container. Please refer the image. It might help you.


Regards,

Manish Jawla

Thanks, but it did not work. I tried placing the new expression in the nested List and in the top one. Neither expanded the display of the results. Still looks like this.

Hi Gonzalo Labarca,

Can you please share your code or oml.

Regards,

Manish Jawla

I am attaching the file. It has a dependency module. Do you need that as well?

Hi,

Please try the below settings for 1st expression Margin top :Auto and width: fill parent, hope this will work, otherwise i need dependency module also to check at my end.

Manish, thanks for the support, I really appreciate the help. It did not work. I am attaching the dependencies

Hi Gonzalo Labarca,

Since its a external database, i cannot access it without credentials, i would like to give my last try.

1. Task Date expression using fixed 6 column width try to change it to fill parent.

2. remove the container from the web block, use it without container.

Hope this will work :(.

Regards,

manish jawla

Thanks Manish. Last recommendation did not work either

HI Gonzalo Labarca,

Did you tried inspecting element from the browser itself?, it will give you the real picture if there is any css or fix width is beimg applied to it.


Regards

-PJ-

Thanks Pramod,


This is what I get when I inspect that element. As you can see, for some reason the list item division has 2 columns. I need to figure how to make sure is only one column.

Solution

All, thanks for your help. I solved. I removed the default class definition for the list and left it blank.

Thanks again

Solution