Can't use version control

  

Hi,


I've made a number of changes to my mobile project to try to add a currentScreen variable so the user can't navigate to the same screen he is currently on. This did not work for me and I wanted to undo my changes. I then got the error message:


'An error occurred while trying to update the app. If you want to retry the update, restart the app. If the problem persists, you can reinstall, but all local data will be lost'.


The error is persisting through restarting and when I try to republish an older version that worked last week, the debug logs say:

ERROR: VersionsManager: Upgrade failed - rolling back to previous application version.µ

And Error Log says:

2017-05-02 09:29:14Willemen
(Willemen)
unable to begin transaction: cannot start a transaction within a transactionDatabaseS1N50-LT2BZ7Detail
2017-05-02 09:29:14Willemen
(Willemen)
Failed to execute canary query (probably due to zombie transaction)DatabaseS1N50-LT2BZ7Detail
2017-05-02 09:29:13Willemen
(Willemen)
Upgrade failed - rolling back to previous application version.
Script error for "Willemen.entities"
http://requirejs.org/docs/errors.html#scripterror


So I can't use version control? Attached is my OML. 

I have copy pasted my project (copying groups of elements as this was easy with the copy paste functionality) into a new project, seeing a quick fix wasn't going to happen and I was stuck like a rhino jumping through a hula hoop.

In some cases, the app could not be updated. Usually when the model was changed. In the most of the cases is enough to uninstall the app from device and reinstall it.  If this error was show on the web emulator, so you need to clean your cache and try again.



Fantato wrote:

In some cases, the app could not be updated. Usually when the model was changed. In the most of the cases is enough to uninstall the app from device and reinstall it.  If this error was show on the web emulator, so you need to clean your cache and try again.



The error was in the native Android app and the iOS Outsystems Now app. I tried deleting the android app and reinstalling it but to no avail. Also copying my OML file and publishing that gave the above mentioned error. 


We also have this Error message "Failed to execute canary query (probably due to zombie transaction)"; Is there already a sollution for this problem?