Communication Error when trying to publish/can't submit feedback either

Communication Error when trying to publish/can't submit feedback either

  

I can't publish, I get the following errors (more on the second error):

Communication error
There was an error contacting 'XXXXXXXX.outsystemscloud.com'.
The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.


Communication error
There was an error contacting 'XXXXXXXX.outsystemscloud.com'.
An error occurred while making the HTTP request to https://XXXXXX.outsystemscloud.com/ServiceCenter/ServiceStudio.asmx. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.


I was able to publish ONCE this morning but nothing since. If I try to submit feedback, it tries to submit it, but then 1/3 way through on bar, it pops up "Could not contact OutSystems. Please try again later.". But oddly, I can connect to the server and choose a project and even outside of the app through a web browser, nothing in sleeping. 

Currently at work and behind firewall, but not sure what ports or what connection it needs to assist the "help desk" with this issue.

Could the servers be going through some upgrade? going on for roughly 6 hours now and no publish.

Mike




Hi Mike,

Service Studio uses standard HTTPS ports: 443. It's probably the firewall that might be blocking or interfering with Service Studio.

Thanks.....I figured, would anyone know the exact URL the IDE tries to connect to? Trying to explain this to the help desk to resolve or open the port. From the error message, it's trying to connect to the webservices which do connect and I see the methods. 

If possible every communication with https://XXXXXX.outsystemscloud.com/* should be allowed