Google Drive Connector DEMO error

Google Drive Connector DEMO error

  

I am attempting to run the Google Drive Connector demo application from Forge.

After registering my project and receiving ClientID, API Key, Secret and Scope, the DEMO just reports back "Internal Error". Is there any place I can go to get more information on type of error is occurring?

Hi Jeff,

Service Center is the place where you can always get more information about errors.

Go to https://<your_server_domain>/ServiceCenter/Error_Logs.aspx, login and check the errors of your app.

João Neves wrote:

Hi Jeff,

Service Center is the place where you can always get more information about errors.

Go to https://<your_server_domain>/ServiceCenter/Error_Logs.aspx, login and check the errors of your app.


I am experiencing the same problem as Jeff and when I go to service center, the error log says NoAccessTokenException. 


Thank you both for your reply and my apologies for responding so late.

I see the details of the problem in Service Center.

It is showing an error of "NoAccessTokenException".

Here are some of the details although I'm not certain what may be needed to help resolve it.

One thing I would like to point out. The Google Drive connector project is registered under a gmail.com account but my Outsystems account is under a different login/account. Could that be part of it?

I have attached a couple of screenshots of my configurations if you think it would help.

Message:
NoAccessTokenException
Environment InformationeSpaceVer: 4 (Id=397, PubId=394, CompiledWith=10.0.603.0)
RequestUrl: https://jwilliam3021.outsystemscloud.com/GDriveConnectorDemo/Configurations.aspx (Method: POST)
AppDomain: /LM/W3SVC/8/ROOT/GDriveConnectorDemo-33-131456846549552718
FilePath: C:\OutSystems\Sandboxes\YLOR02005\Platform Server\running\GDriveConnectorDemo\Demo.aspx
ClientIp: 69.132.143.38
Locale: en-US
DateFormat: yyyy-MM-dd
PID: 80548 ('w3wp', Started='7/19/2017 3:08:19 AM', Priv=213Mb, Virt=17911Mb)
TID: 23
Thread Name: 
.NET: 4.0.30319.42000