how to upgrade HTTPRequestHandler component

how to upgrade HTTPRequestHandler component

  

in my production environment 

in the service studio, it shows verison 9.0.1.9

but when i open in integration studio, it show version 5.0.13 and this version does not have RunJavaScript action. 

This does not happen in my dev and uat environment. how do i upgrade the components in production to 9.0.1.9?





i suspect the component is downgraded when i do deployment, but its a system component...

Hi Linguo,

What is the version of system components in Service Center of that environment?

Regards,

António Pereira

where to see the version? system component is not in the app listing

Hi,


They are shown in Service Center.

https://www.screencast.com/t/uhRR6pxR4vs


Regards,
João Rosado

it shows 5.0.13, how do i upgrade it ?

i republished the previous version. but how did this happen, not sure if i deploy some app. again, whether it will happen...

is this similar issue?  this app has no dependence, but how come QA enviroment showing warning, but dev and production is not and version info are alll the same

Hi,


 A solution file with all the System Components (System_Components.osp) is inside the Platform Server folder on the server where the platform is installed. You can publish it in Service Center. Full instructions for this are in the Installation Checklist  if you need more help.


The old version can have been published if you installed some old solutions that include it. This can happen for example with old Forge components that are still in the Solution format (instead of the new Application Package format).


As the the problem with those warnings, what does the warning say?


Regards,

João Rosado