Wikitude Cordova Plugin

Wikitude Cordova Plugin

  

Hello Readers,

I am trying to use the wikitude cordova plugin in outsystems.

I try to use the following github link "https://github.com/Wikitude/wikitude-cordova-plugin".

The extensibility configuration is written how it should be.


However there is an error appearing about a missing package. Where this missing package should be or how to include it in the project is a big question for me.

The error message we are getting is attached in this post.


Is there anyone who has experience with the wikitude cordova plugin in outsystems and knows howto fix this?

regards,

Stijn


Solution

From the outsystems support:

we did a review to the possible error associated with this plugin, it seems that it uses a dependency with the same name used by the OutSystems shell. To enable a proper compilation, it was necessary to create a fork of the plugin where it doesn't use the same dependency. 


You should be able to compile your OutSystems mobile application by using the following plugin version: https://github.com/vmfo22/wikitude-cordova-plugin

Solution

stijn klaassen wrote:

From the outsystems support:

we did a review to the possible error associated with this plugin, it seems that it uses a dependency with the same name used by the OutSystems shell. To enable a proper compilation, it was necessary to create a fork of the plugin where it doesn't use the same dependency. 


You should be able to compile your OutSystems mobile application by using the following plugin version: https://github.com/vmfo22/wikitude-cordova-plugin

I have generated the Android app with the plugin https://github.com/vmfo22/wikitude-cordova-plugin.

This worked well.