external site to facebook and then stuck on fb page

external site to facebook and then stuck on fb page

  

Hello,

im new to all of this and i was hoping some one could help me out

i added 2 external site's to my app. one for instagram and one for facebook. the instagram link is working fine. but when i press the facebook link i go to the page but then im stuck there.i can navigate on the page but there is no return button. i cant press back i have to close the app and restart it.

i created a external site and put the facebook URL in there 

SyntaxEditor Code Snippet

https://www.facebook.com/JuliettaFashion/?hc_ref=SEARCH

Greetings,

Mark



Hi Mark,

I've tested with a web and mobile app and the same didn't happen to me. Can you share more details? Screenshots or even an oml with the use case.


Regards,

António Pereira

António Pereira wrote:

Hi Mark,

I've tested with a web and mobile app and the same didn't happen to me. Can you share more details? Screenshots or even an oml with the use case.


Regards,

António Pereira

Hello António,

sure no problem i uploaded my oml file. thanks for your fast reply! i was also wondering how to change the height of a button widget.

Greetings,


Mark


I created a mobile app with your module and tested it on my device and when I press the back button it works. Maybe that is something related with your device or operating system.

To prevent your issue and create a more common mobile experience, to be able to open url's from your application and be able to go back, I'd recommend you to use the in InAppBrowser Plugin. You'll get the same experience when you open a site in the Facebook app. Take a look.

Regarding your other question, just add a CSS class where you set the "height" attribute to the value you want. Example:

Does it help you?

Regards,

António Pereira


yes thank you i got the button part. but how do i get the InAppBrowser Plugin to work? i just right click UI flows and add the dependency? and how do i go from there. many thanks for ur help !


Greetings,


Mark

Hi Mark,

Based on what is written, "Use the Open client action in order to open the given URL. The provided URL must contain http or https scheme"

Do you find the client action?

António Pereira wrote:

Hi Mark,

Based on what is written, "Use the Open client action in order to open the given URL. The provided URL must contain http or https scheme"

Do you find the client action?



yes i have i made an on click , and then first let it check if the inappbrowser is available. then i let it open the in app browser.  in what way am i supposed to put the URL in the open browser action. it's not the same as in the external URL. sorry for the many questions i just started with this and i really want to learn! thanks for ur assistance.



Greetings 


Mark

Solution

Hi Mark,

Feel free to question everything :)

I've implemented it so you can see. The OnClick action,

And the values for the Open action,

P.S. Don't forget to generate a new native app or the plugin won't be available in your app.

Does it help you?

Regards,

António Pereira

Solution

António Pereira wrote:

Hi Mark,

Feel free to question everything :)

I've implemented it so you can see. The OnClick action,

And the values for the Open action,

P.S. Don't forget to generate a new native app or the plugin won't be available in your app.

Does it help you?

Regards,

António Pereira


i got that part implemented. all error messages are now gone. but what exactly do u mean with generate a new native app? i need to create a new app and load my oml file in there?. when i test the app i get the message ''cordova is not defined'' when i click on the link. i guess this has to to with generating a new native app. 


oh sorry it only works on my phone ofcourse! 

thank you very much!

greetings 


Mark

There are some cases when you need to generate a new native build (check this doc for more info) to see your new developments to an app.

The Preview in Devices mode in the browser doesn't have the plugins you've added to your app. You can use OutSystems Now (if your plugin is supported by OutSystems) or you have to test directly on your device (more info here).

Greetings,

António Pereira

António Pereira wrote:

There are some cases when you need to generate a new native build (check this doc for more info) to see your new developments to an app.

The Preview in Devices mode in the browser doesn't have the plugins you've added to your app. You can use OutSystems Now (if your plugin is supported by OutSystems) or you have to test directly on your device (more info here).

Greetings,

António Pereira

yes it all works perfectly now! thanks a lot!  i have another question tough:P. i managed to change colors of buttons and text but i can't seem to find the menu icon. it's currently white and i added a image with a white background as header background. where can i change it's color to black? i looked i the style sheet and tried different things but i can't seem to find the wright piece of code. 

and how do i change the background color of a screen?

many thanks in advance !


Greetings 

Mark


Hi Mark,

You should have created a new thread for that question since it will be lost here :(

But..

In the stylesheet, try this:

.content {
    background-color: red; /* change to your color */
}