Data Synchronization Exercise "problem"

Data Synchronization Exercise "problem"

  

Hi,

Any help would be appreciated. I'm just stuck at the "Data Synchronization Exercise".
I was trying to test the offline saving capabilities, and i keep getting this error: "Request failed with an error".

TrueChange says the module is valid.

I'm attaching my ToDo module. If anyone could give me a hint.

Thank you!

Hi Mattia,

Can you try to attach the module again? It is uploading the module for 10 minutes..

Ok, it seems to be difficult to upload the file. Here's a link to download it: https://drive.google.com/open?id=0B-M19HmGhlkMcmlWZmh0dXVNeG8

Hi Antonio,

Did you manage to download the file from GDrive?

Thanks,
Mattia

Hi Mattia,

Sorry, I'm quite busy in these days. 

Can you upload the ToDo_Core module and tell me the screen button where that problem is happening?

Regards,

António Pereira

Hi Antonio,

Here is the link to my ToDo module: https://drive.google.com/open?id=0B-M19HmGhlkMcmlWZmh0dXVNeG8

I try to upload again the module, but there seem to be problems in uploading the file...
The problem is that when i try to create a new ToDo and i try to save, in offline mode (i'm testing the app via the OutSystems app, on my iPhone), i get that error: "Request failed with an error".

I think that maybe the problem is on the ToDoDetail screen, or maybe in one of the actions... I don't know, i thought i followed precisely every step in the "Data Synchronization Exercise", but maybe i misread something.

Thank you again for your time

Hi Mattia,

I mean the ToDo_Core module. It's a dependency of your app

Can you upload it?

Ah, ok, i didn't understand. Here it is.
And here is the GDrive link to download it: https://drive.google.com/open?id=0B-M19HmGhlkMbWxHTnBFejh5YzA

Hi Mattia,

I'm having some troubles to install your app and understand the problem. Did you check the logs in ServiceCenter?

Regards,

António Pereira

António Pereira wrote:

Hi Mattia,

I'm having some troubles to install your app and understand the problem. Did you check the logs in ServiceCenter?

Regards,

António Pereira

Hi Antonio,

I checked the logs, but i don't know what to look for... There don't seem to be errors of any sort.
I'm attaching the logs of ToDo_Core.

Thank you,
Mattia

Solution

Hi Mattia,

I'm having problems to publish your solution :(

I went to your code and I found something that could be the source of your problem. In the "SaveOnClick" client screen action of the "ToDoDetail" screen, you are calling a server action even if you are offline (in case it is a new ToDo):

Check if this is what is expected in the tutorial and try to remove this call when you are offline.

Did that solve your problem?


Regards,

António Pereira

Solution

António Pereira wrote:

Hi Mattia,

I'm having problems to publish your solution :(

I went to your code and I found something that could be the source of your problem. In the "SaveOnClick" client screen action of the "ToDoDetail" screen, you are calling a server action even if you are offline (in case it is a new ToDo):

Check if this is what is expected in the tutorial and try to remove this call when you are offline.

Did that solve your problem?


Regards,

António Pereira

Hi Antonio,

Now it works, i misread that part. Thank you very much!