Environment issue: Date Field format issue with change in environment

Environment issue: Date Field format issue with change in environment

  

Environment : cloud

Platform Version : 10.0.407.0


I am facing issue with date field format while the application is deployed to the higher environment.


In Development environment, I have format MM-DD-YYYY.


In QA environment, the default format is YYYY-MM-DD. It works fine with default. However, the requirement is to have MM-DD-YYYY. 


I have tried changing the date format from the Admin console and republishing the application. However, It gives system validation error that date required.



We are also facing the same issue. When changing the dateformat in service center, for some reasons all client validations are giving the error 'date required', with the new date format.

Have you tried to republish?

Harlin Setiadarma wrote:

Have you tried to republish?

Yes I did. After changing the format in environment configuration.


Anyone with the solution or idea on how to solve this issue?

Niels Favreau wrote:

We are also facing the same issue. When changing the dateformat in service center, for some reasons all client validations are giving the error 'date required', with the new date format.

Hi Niels,

Thanks for the response. 

Can you please share the solution if you have figured it out or the problem why this is happening?

I have been trying a lot to figure out the problem but no luck yet.

Thanks.


Open support ticket to Outsystems Support is your best bet. 

Anyone ahs founda solution for this problem yet???

Niels Favreau wrote:

Anyone ahs founda solution for this problem yet???


Hi Niels,


Have you already created a ticked in OutSystems support? (https://www.outsystems.com/SupportPortal/)


I would say is the best approach to solve the issue.


Regards,

Hi,


I also had to change the date format on an environment, and when opened an app I was getting the "Date required" error.

I erased all the browser cookies, and restarted it. After that the error was gone.


Best regards,

João Nobre