Date from form doesn't save

I have a form where one of the options is to select a date. It's limited to a 4 year period, 2 year ago to 2 years ahead. While filling out the form it works fine. After the form is saved, if I go to the list of entries and select the entry, the date is always 1900-01-01. Any thoughts? 

Attaching .oml just in case. For "Target Date" Field on NewTask page. 

i cant see the oml attached ..can you please check ?



Says processing still...I've attached it here as well. 

Any thoughts?

Hi Artur,

That behavior is strange. 

I've downloaded you OML and it looks fine.

Have you tried to debug and stop right before saving to the database to check which value is being sent?

Kind regards,



Hi Artur,

I think the problems stands in the "DateFormat" property of the Input_Calendar that might have a different format from the one you have in the server configurations. I tried to remove the value you have there and it works for my server configurations.

If you want to use that DateFormat value, try to convert it to the format you have for your environment (in the OnUpdate property of the Input_Calendar) or to the standard #YYYY-MM-DD#. That should fix your problem.

Does it solve your problem?


António Pereira


I have seen problems with DateFormat and the input widget too.