[Pushwoosh Plugin] Generate iOS app failing after adding Pushwoosh plugin

Forge Component
Published on 2018-12-19 by OutSystems R&D
11 votes
Published on 2018-12-19 by OutSystems R&D

I added pushwoosh plugin to my Outsystems 10.0.302.0.

In my mobile application, I added the dependencies and tested for Android and it is working fine. I even took the Android version to Production and it all worked fine.

Now I followed the steps for iOS and did everything as mentioned. But when I try to generate the app from Service Studio, the following error message was displayed:

"The following errors have occurred:• iOS: An unexpected error has occurred while generating your application. Please try again. If the problem persists, contact OutSystems Support."

I even tried restarting Service studio several times, but no luck.

Please let me know how to fix this ?

Hello, Kartick,

Sorry to hear you're experiencing this issue. Since we suspect this might be an issue with the app generation, could you please open a support case through the support portal? Here's some help on how to do it. This is really important so we can better track the possible problem and, ultimately, better help you.

Be sure to mention your app name and approximate dates for the problematic builds, so we can speed up the lookup process.

In the meantime, if this is blocking you and if it's feasible, could you try to remove the Pushwoosh plugin from your app and see if the problem persists?

Thanks and best regards,

Carlos Simões

Thanks Carlos.

I have already created support case simultaneously when I created this post. The case id is 2013109.

I cannot remove pushwoosh plug-in since sending notification is an important part of our app and also the new change or update that we are bringing to iOS App store is the push notification feature. We have already published this new change or update to Android Play store.  

Hope to get this issue resolved sooner.


Thank you Carlos for pointing out the issue.

The issue was that I was using an older version, after installing the latest version, iOS app generation was successful.


Awesome! Thanks for sharing it with everyone!

Feel free to reach out if you need further help!

Best regards,

Carlos Simões