New in OutSystems 10 - Aggregates in separate windows!

New in OutSystems 10 - Aggregates in separate windows!

  

Hi!

We have great news for you! We’ve heard your feedback, and Development Environment v10.0.606.0 has an option to pop-out an aggregate into a separate window!

Here's a demo of it working:


With this you can:

  • See Action Flows and Aggregates side-by-side;

  • Open multiple aggregates at the same time for comparison;

  • Move the aggregate window to your secondary monitor.


All you have to do is to click in the Pop-out button, next to the breadcrumb.

And this aggregate will open in a separate window, as well as other aggregates you open in the future.


Wait, there is more! There is no Pop-out without Pop-in! :)

So for those situations where you need to see the old "full screen" version, click the "Pop-in" button in the window title bar:


... and the aggregate window will get back to your Development Environment window.

How cool is that?

Try it out and give us your feedback!

Thanks!

Also, there is also another nifty feature for top productivity!

When you create a new aggregate, now you can just click to add a source - no need to drag & drop!

I've been waiting for this one for ages :)

Ricardo Ferreira wrote:

Also, there is also another nifty feature for top productivity!

When you create a new aggregate, now you can just click to add a source - no need to drag & drop!



Cool  Image result for thumbs up images

Looks good:) tnx

Finally the aggregate into a separate window!!! :')

This is cool, but the problem is that this version of Service Studio (10.0.606.0) introduced a new bug:

Whenever you are debugging, if a new request is done and it also stops on your breakpoints, you loose the ability to go back to the first request. Before this was possible, a list of requests were maintained and you could switch from one to other... Not anymore...

Best regards,

PC

Here is a video demonstrating the issue:

https://www.screencast.com/t/0Xb0kGEechd

I start the debugger, hit OK, and while on debug hit NOK on other browser window, I completely loose the ability to go back to the first request even though the request is still stopped in the debug point (that is why when I stop debugging it finishes properly)

Please check this issue.

Best regards,

PC


Yeah,

Great to hear and see!

Really cool!

Finally some improvements on the aggregates in terms of developer experience   

Pedro Coelho wrote:

Here is a video demonstrating the issue:

https://www.screencast.com/t/0Xb0kGEechd

I start the debugger, hit OK, and while on debug hit NOK on other browser window, I completely loose the ability to go back to the first request even though the request is still stopped in the debug point (that is why when I stop debugging it finishes properly)

Please check this issue.

Best regards,

PC


Hi Pedro,

Many thanks for your detailed report.

We just released a new Development Environment with that situation fixed:

Development Environment 10.0.607.0

Thanks!

Just tested, it's working perfectly.

Gratz on the fast resolution

Best regards,

PC


Fantastic Pedro! Thanks for the amazing fast feedback! You literally validated the fix 5min after the release was out. :)

Joao Neto


Pedro Coelho wrote:

Just tested, it's working perfectly.

Gratz on the fast resolution

Best regards,

PC



No we need a refresh data button :)

since 502::

  • Added the ability to refresh preview data in aggregates by pressing "Shift+F5" on an Aggregate View. (RPD-1494)

The pop-up is back   

J. wrote:

since 502::

  • Added the ability to refresh preview data in aggregates by pressing "Shift+F5" on an Aggregate View. (RPD-1494)

That's not a button :) but good to know!


that's cool

Thanks a lot for the popup :D amazing!

This is super cool!!   

Great to read this.....I didn't notice the little button untill now :)