[Dublin Template] Struggling to Add SubMenu

[Dublin Template] Struggling to Add SubMenu

  
Forge Component
(24)
Published on 15 Nov (4 weeks ago) by OutSystems R&D
24 votes
Published on 15 Nov (4 weeks ago) by OutSystems R&D

I'm embarrassed to say that I can't figure out how to add submenu items to the Dublin theme. I've tried dragging webscreens onto main menu entries, and I've added submenu items to the appropriate static database.  I've also tried adding links in the Menu tree, but these links don't funtion as proper submenu items.  Can anyone point me in the right direction?  Thanks in advance!

Alan R.


One more observation re. my struggles with submenus - I just noticed that if I change the module's Default Theme property from 'Dublin' to a different default theme (the one automatically created and named for the module), then webscreens CAN be dropped into the menu and submenu placeholders in the tree... everything works fine.  But if the modules Default Theme is switched to 'Dublin', screens can no loner be dragged into menus - a red-circle-slash icon appears.  Does anyone know why this is happening?  It's preventing me from using 'Dublin', which is a great-looking them.  Help!  Thanks.

1. Double click Common\Menu

2. Click on a menu item (the RichWidget one, use the breadcrumb or widget tree)

3. Click on Show All Placeholders button

4. Drag and drop screen on Sub-Menu Placeholder


FInal appearance:


Widget Tree Structure:

Solution

Harlin, thanks very much for taking the time to reply and for posting the clear screen-images.  I never would have known about or found the "Show All Placeholders" buttons without the images.  Thank you!

 

Solution