[Salesforce Connector] Unable to integrate to our salesforce sandbox using Salesforce connector

[Salesforce Connector] Unable to integrate to our salesforce sandbox using Salesforce connector

  
Forge Component
(14)
Published on 2017-12-19 by OutSystems R&D
14 votes
Published on 2017-12-19 by OutSystems R&D

Hello,

I recently tried the salesforce connector and created a sample account using http://developer.force.com/ which is working just fine with OutSystems. I tried to replicate the same integration using the sandbox created for this POC,  but it is not establishing the connection to the server. 

Just wanted to know how to provide server url (of our sandbox environment) and establish a successful connection. I think the connector is always loading the developer.force.com URL and the authentication is failing. 

Simply, I am looking for steps/sample to integrate our own salesforce sandbox for which I already have user name, password and security token. (I can login to the sandbox using this credential using browser). 

Thanks,

Arun

Hello Arun,

You might have solved this by now.

Please open the login page of the Sales force sample application. Now open the Login screen action and  you will see "SalesforceLogin". The first parameter to "SalesforceLogin" is "ServerUrl".  Please enter your  own salesforce sandbox url and you are good to go.

Thanks

Hello, I'm running into a similar issue when connecting to our sandbox environment. When setting the ServerUrl, I'm receiving following error: 

Login Failed: Client found response content type of 'text/html; charset=UTF-8', but expected 'text/xml'. The request failed with the error ... 

I am able to connect to production environment without any issues.  Any ideas?

I had the same problem until I found the answer in this post:

https://www.outsystems.com/forums/discussion/15756/response-content-type-of-text-htmlcharset-utf-8-but-expected-text-xml/

As suggested, I changed the value of the ServerUrl to "https://test.salesforce.com/services/Soap/u/25.0" and that worked for me.