Forge Component
(42)
Published on 25 Nov (3 weeks ago) by Afonso Carvalho
42 votes
Published on 25 Nov (3 weeks ago) by Afonso Carvalho

Hi, 

Can anyone walk me through on how to use this component. I'm having trouble using it with my XML Response from SAP Gateway Service. Thanks in advance!

Hi Suraj,

I'm receiving below errors.

[1]Unable to load xml document:*xml response*

[2] 'm' is an undeclared prefix. Line 1, position 696.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.LookupNamespace(NodeData node)
   at System.Xml.XmlTextReaderImpl.ElementNamespaceLookup()
   at System.Xml.XmlTextReaderImpl.ParseElement()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
   at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.LoadXml(String xml)
   at OutSystems.NssXmlRecords.CssXmlRecords.MssXmlToRecordList(String ssXml, Object ssRecordList, RLRecordXmlConfigRecordList ssXmlConfig, Boolean ssIgnoreXMLDeclarationAndNS, String ssAttributePrefix, RCDefaultXmlConfigRecord ssDefaultConfig, Boolean ssBypassRootRecordListNode)


Hi All,

Can anyone please help me to create structure to hold xml node attributes.


I already created below structure but it is not working

Thanks

Shashikant Shukla

Hi Shashikant,

What version of the extension are you using? There was a bug that prevented the extension from recognising values within attributes - can you update to the latest?

Yes I am using updated version but still getting same issue.


Can anyone help me.


Regards

Shashikant Shukla

I implemented some of your fields as an example - it won't output to screen, but you can see it happening in debug. Let me know if you have any questions.