[ardoHTTP] This request has been blocked

[ardoHTTP] This request has been blocked

  
Forge Component
(15)
Published on 2015-06-04 by Ricardo Silva
15 votes
Published on 2015-06-04 by Ricardo Silva

Hello.
I am doing a HTTPRequest with the HTTPGet action and its giving me the folowing error:

Mixed Content: The page at 'https://...' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://....'. This request has been blocked; the content must be served over HTTPS.
(anonymous) @ ....MobileFlow.UrlLinksDetail.controller.js?ASrgg20_Ss+XWFU1rqGikA:164
e.safeExecuteJSNode @ Controller.js:278
(anonymous) @ .....UrlLinksDetail.controller.js?ASrgg20_Ss+XWFU1rqGikA:117

Any one had the same probles or know how to fix it?


Thanks a lot.
Francisco Freire

ardoHTTP works on the server side.

The error you are seeing is being launched at the client side (Javascript in the mobile application).

I do not think this is a problem with ardoHTTP but possible some misconfiguration of your server.


What are the URLs that are being shown? are they your server's address, or the address you're inputting ardoHTTP?

I am sure it is not a ardoHTTP's problem because i tested on my personal environment, using the ardoHTTP to get the page and using it in my page(to mantain the domain) that way is easyer to use this page on the mobile app iframe.

When passing this code to the client environment it gives me this erros.

I was just wandering if someone had the same problem.

Thanks a lot :)

I found out the  problem.
Long story short, i was missing a "?" in the link i was using.
Now is working fine.
Thanks for the help and keep up the good work :)
Francisco Freire.

Does this mean that I would not have the problem?