[Silk UI Web] SectionIndex and  SectionExpandable don't display diacritics correctly

[Silk UI Web] SectionIndex and  SectionExpandable don't display diacritics correctly

  
Forge Component
(52)
Published on 15 Nov by OutSystems R&D
52 votes
Published on 15 Nov by OutSystems R&D

I have SectionExpandable and SectionIndex web pattern on the same screen as you can see in the screenshot below.


The problem is that the SectionIndex display the single quote (') as x26' in the link text. 

The IndexLabel property of SectionExpandable in the sevice studio is set to "Veelgestelde vragen tarieven behandelingen ziekenhuizen en DBC's" and it generates the following code in html

<a class="Section-anchor" title="Veelgestelde vragen tarieven behandelingen ziekenhuizen en DBC\x26#39;s" name="section1"></a>

The SectionIndex is using the title property of SectionExpandable above to generate the link text on the right.

I have tried to excipliictly set the value of the IndexLabel to "Veelgestelde vragen tarieven behandelingen ziekenhuizen en DBC's", yet the link text on the right side of the screen is  displayed as "Veelgestelde vragen tarieven behandelingen ziekenhuizen en DBC\x26s"

anyone have a solution for this problem?

Thank you.



Hi Nour,

I don't think you can work around that because the IndexLabel ends up being used as the value of an attribute in html. Thus, it can not contain single quotes and that is why that property is escaped and the single quotes removed.

Cheers,

José