Consider the following scenario:

- eSpace1 (front-end) references an action defined in eSpace2.

- eSpace2 references an action defined in eSpace3.

It's easy to debug the action in eSpace2 by selecting eSpace1 as the entry point, but how do I debug the action in eSpace3? And what if I had a 4th eSpace, how would I go about debugging that?

Hi Aurélio.

You can have multiple debugging levels, sure.

If all the references are refreshed, you should be able to debug an action in eSpace1, from eSpace2 and then debug eSpace3 by choosing the entry point as the eSpace2. 

Hi Gonçalo,

I've tried that, but it doesn't seem to work. I selected eSpace2 as the entry point for eSpace3, and then went to "Debugger/Debug eSpace2 in the Public Area", but my breakpoints are never hit. Do I also need to have eSpace2 in debug mode, with eSpace1 as its entry point?

Hi Aurelio.

Yes, you can try to do that, it should work. 

Hi Aurelio. The entry point that you select is always the eSpace that is serving the request. Hence the name "entry". Usually you can guide yourself just by always attaching to the public area of the web screen.

So in your example you would debug the public area of eSpace 1, even though the action from eSpace 3 is not directly referenced from eSpace 1.

Hi guys,

Well, this is frustrating. I still can't get it to work. What I've tried:

1 - On eSpace2, select eSpace1 as entry point and debug it.

2 - On eSpace3, select eSpace2 as entry point and debug it.

Still, my breakpoints on eSpace 3 never get hit.

I can't select eSpace1 as the entry point for eSpace 3. I assume this is because eSpace1 doesn't directly reference eSpace3.

What am I missing?


Hi Aurélio,

This usually works for me (and comes in line with what Leonardo said):

  • From eSpace1 reference something from eSpace3 (even if you do not use it in eSpace1)
  • Publish eSpace1
  • Now, on eSpace3, you should be able to select eSpace1 as entry point

See if this also works for you.




Hi José.

Yeah, that will work for sure but should be avoided, since you'll create new references and sometimes you can forget to remove them. But for a quick debug that's the easier way to perform it. 

Hi Gonçalo,

Yes. That is just a quick fix and then the reference should be removed.



Hi José,

It feels like a bit of a hack, but it works. Thank you!

I just simply copy the action or screen to the espace where I try to debug.  

You don't need to add references, just try to remove (disable and enable them should be enough as well) and add the breakpoints AFTER the debugger is running. I had the same problem a while ago and both these solutions were provided by OS Support.



We found you can only debug in one module - in version 11.6 you cannot have debug running in the UI level module and debug down in the _CS CRUD Wrapper module. 

You would have to not start the UI level debugger, and start the _CS level debugger and then it will stop at the breakpoints in the CRUD wrappers.