Login credentials not being asked - Anonymous field is not selected in app 

Login credentials not being asked - Anonymous field is not selected in app 

  

Hi,

I'm  doing the tutorials, specifically the ToDo Mobile App as indicated in the "Developing Outsystems Mobile Apss - creating appplications" document.

In Part 2 Section 5, we are suppose to create a new user and define username and password. When the app is Opened in Browser, username and password should be requested, as indicated in the tutorial doc, but this is not happening.  HomeScreen  is not set as Anonymous. 

The only way I found to be asked for Credentials is to select "Login" as the Entry point, within the 1-Click Publish Development Tab, and then it works as described in the Tutorial Doc (However this is not indicated in the doc so I might either be doing something wrong or the doc is missing a step). 

Thanks for your support! Platform version 10.0.609.0

Gaby

Check if you have your screens are marked with the role anonymous. If they are, there is no need to login to go to a web screen.

Marked the registered or any role and then you will be asked to do the login if not logged yet, when trying to access the page.

Cheers

Eduardo Jauch

Edit. If login is not marked as anonymous try to logout and access this page.

Eduardo Jauch wrote:

Check if you have your screens are marked with the role anonymous. If they are, there is no need to login to go to a web screen.

Marked the registered or any role and then you will be asked to do the login if not logged yet, when trying to access the page.

Cheers

Eduardo Jauch

Edit. If login is not marked as anonymous try to logout and access this page.

Screen is not marked as anonymous and the registered is marked; still I don't get asked for credentials. It might happen that both users are still logged-in, as you pointed out, but I see no way to logout, I've tried to mark them as INACTIVE users but I still don't get the login credentials when publishing the app. 

Thanks Eduardo! 

Cheers, 

Gaby

 


Hi Gaby,

Could you provide the OML so we can take a look? :)

Cheers,
Eduardo Jauch

Hi Gaby.

The user might have logged in with the "Remember Login" setting. In this case, an authentication cookie is stored on the user's computer, and he/she is able to return to the application without being requested credentials, even after closing the browser. Logging out should clear this cookie, though.

Inactive users are only checked during the login. So if the users aren't being requested to log in, then inactivating them is of no use.


You can check the logs of screen accesses if the User Id is set. Go to Service Center, then on Monitoring -> Web Requests. Locate the screen accesses from those users (you should be able to locate them by the screen name) and check which is the value on the User column. This will tell you the user id. If the user id is 0, then you have an annonymous access, and like you've said it shouldn't happen. But if the user id is not 0, then it has the registered role.

Eduardo Jauch wrote:

Hi Gaby,

Could you provide the OML so we can take a look? :)

Cheers,
Eduardo Jauch

Hi Eduardo! Is the file attached enough? I'm starting with the platform so I still have a lot to learn! thanks for your support! 

cheers,

Gaby 


Hello Gaby,

I'll take a look at night. If someone is able to look before, the better ;)

Cheers,

Eduardo Jauch

Solution

Hi Gaby

I look into your OML and at first I can't say that there are something wrong.
I did a small app to test, here.

Besides adding a text to the home page, I didn't changed anything from the created app.

When I am logged in, I can click the "burger" menu and it will open the menu for me:

As you can see, there is a "Logout" menu item at the bottom of the screen.
You don't see this when you click the burger menu?

Cheers,
Eduardo Jauch

Solution

Thanks Eduardo for your time! 

I could definetly logout now. I didn't know the platform was already building the "Burger" Menu for me (I thought it was an icon in the template). It's amazing!! 

Cheers, 

Gaby


 

Glad to know it helped :)