Mobile Local Storage

Hi community!

Did you guys ever encounter after Offline Data Synchronization, the syncing didn't fully copy all the data to the local storage? I was trying to sync worth 2,000 records but it only copied like 1900. Is there some kind of limit? My other local storage with 5000 records doesn't have any a problem syncing. This only happens in one entity and it's local storage counterpart.


Kind regards,


Hi Louise,

There shouldn't be any limits besides device storage availability. Are there any errors during the sync? Have you tried logging the sync to check whether is runs ok?

Hi João!

Right now, there aren't any errors during the syncing (I wish there was even an error message to track it), it just skips certain data which is really weird. For example it will skip IDs 1-5, it will start 6-50, then skips again and vice versa. 

I tried syncing only those skipped data/items using a filter. They successfully synced this time but when I remove the filter and don't put any filters (use default), it just keeps on skipping these certain IDs/items. 

I thought it just got something to do with a limit. But since there are no limits, is this (might be) a bug for version ?

Thank you again!

Kind regards,


Can you share the oml?