my app's links behave different in different devices

my app's links behave different in different devices

  


Hi.

Im making this mobile app for the first time and I checked my app using outsystems now and all the links were properly working in LG G2 device but when I checked the same links in outsystems now using Huawai P9 and samsung they simply wont open. Why is it so?


Im using same outsystems now versions on all devices.As outsystems wont install on lower versions of android but 4.4 and above so all the devices are above 4.4.

Hi Hafsa,

Regarding your question I have some questions in return before we are able to answer.

1. What do the URL's look like?

2. Are the URL's opened in external apps or just in the app itself?

3. Are the apps that are needed for these apps available on all devices?

4. How did you implement the URL? (screenshot of a piece of code would help)

Kind regards,

Remco Dekkinga

Remco Dekkinga wrote:

Hi Hafsa,

Regarding your question I have some questions in return before we are able to answer.

1. What do the URL's look like?

2. Are the URL's opened in external apps or just in the app itself?

3. Are the apps that are needed for these apps available on all devices?

4. How did you implement the URL? (screenshot of a piece of code would help)

Kind regards,

Remco Dekkinga

Hi Remco,

In reply to your points, let's say for example http not https

1).”http://www.google.com/some link"

2).they open in external website with http protocol.

3).The links are not of different apps, they are of an external website to whom my mobile app has a link to.

4). As I said in point 2. "Http://www.google.com/some link" 

I have used them in my menu (hamburger) and bottom bar.

Regards,