Custom splash screen has no image

Custom splash screen has no image

  

For my app, I would like a custom image. Instead, I get a white screen where an image is expected. In the code, the reference seems incorrect. What can I do to fix it?

Goal is a splash screen, like in this blog post: https://medium.com/cesarafonso/going-beyond-with-your-outsystems-mobile-app-10ce3898fa74

My app has implemented it, like in: https://success.outsystems.com/Documentation/10/Delivering_Mobile_Apps/Customize_Your_Mobile_App/Use_Custom_Splash_Screens (note: the path is without the starting '/' as opposed to the documentation)

And resized it with: http://apetools.webprofusion.com/tools/imagegorilla

But the references to the screen in the Android application seem incorrect:
- rename app.apk to app.zip
- open app.zip/res/xml/config.xml
- See reference: port-xxxhdpi ,,res/android/drawable-port-xxxhdpi/screen.png
- Look up file: app.zip/res/drawable-port-xxxhdpi (folder does not exist)
- Instead, it is named: app.zip/res/drawable-port-xxxhdpi-v4/screen.png (the image looks correctly)

My extensibility config (summarized):

{
    "resource" : "ApeToolsGeneratedAssets.zip",
    "splashscreens" : {
        "Android" : [{
            "resource" : "Android/res/drawable-xxxhdpi/screen.png",
            "density" : "port-xxxhdpi"
        }]
    },
    "preferences": {
        "global": [{
            "name": "SplashMaintainAspectRatio",
            "value": "True"
       }]
    }
}

Platform version: 10.0.603.0

Hello Bram.

In the extensibility configuration, use lower case for "android".

Change from:

    "splashscreens" : {
        "Android" : [{

To:

    "splashscreens" : {
        "android" : [{


Let me know if it works.


Thanks for the reply. Unfortunately it doesn't work.

Also see the attachment; the file on the right is: app.apk/res/xm/config.xml (highlighted the reference to the screenfile), on the left is the directory listing of app.apk/res.

Current extensibility config (summarized):


{
    "resource" : "ApeToolsGeneratedAssets.zip",
    "splashscreens" : {
        "android" : [{
            "resource" : "Android/res/drawable-xxxhdpi/screen.png",
            "density" : "port-xxxhdpi"
        }]
    },
    "preferences": {
        "global": [{
            "name": "SplashMaintainAspectRatio",
            "value": "True"
        }]
    }
}


Solution

Hello Bram.

You're missing a preference to say how much time the splashscreen show remain:

{
    "preferences": {
        "global": [{
            "name": "SplashMaintainAspectRatio",
            "value": "True"
        },{
            "name": "SplashScreenDelay",
            "value": "3000"
        }
]
    }
}


Note that you can hide the splashscreen yourself as highlighted in the post you mentioned (there's a how-to video in the end of the post, around 2:07).

Thanks


Solution

Thanks César!

This works surprisingly. In the OutSystems documentation is no mention of the option to be required.
In combination with hiding the splash screen image manually, the splash screen is shown as short as possible.

The paths still seem incorrect in the config.xml-file, but it works anyway.

In summary: Great solution!