how to disable the backspace key in one form

how to disable the backspace key in one form

  

Hi 

I have a form, but whenever I press inadvertently the BACKSPACE key in the fields that are not possible to edit, the page comes back to the homepage. How to prevent the use of the backspace? Thanks.



Hello Jorge, 

It might exist another way to do that, however, the one i know is based in 3 steps:

1. On your webscreen properties->Advanced->Javascript you can set a function, p.e.:

function checkChanges() {
    if (unsavedChanges === 'True') {
        return "Discard changes?"; }

}

 On your webscreen Extended properties, set:

onbeforeunload 
= "return checkChanges()"

2. Drag and drop a JQUERY weblock from SilkUIFramework->Development to your webscreen (best practice is placing it on the bottom of the screen) and set the "unsavedChanges" variable value to false, so when it renders the screen in the first time it hasn't any changes applied to your form as expected:

"var unsavedChanges = 'False';"

3. In every form input that you want to perform changes, set the following Extended Property:

onoschange 
= "unsavedChanges = 'True';"


Hope i helped, let me know if it worked for you.

Hi Jorge,

Please take also a look on this solution:

https://www.outsystems.com/forums/discussion/8206/how-to-disable-back-button/#Post58684


Hope it helps you!

it is not possible to use SILK UI here... forbidden. The other option: I cannot open any OML in any way. Forbidden too. Forge components are forbidden as well.


My account is set to OS 10 and here they only have the OS 9 . I cannot install anything at all and I do not hold a pc (a pc of mine of course) at the moment. So I would need screenshots...

It should be possible to have an option to set the OS version in our environment. I do not know why this was not thought...