how to disable client-side automatic validator?

how to disable client-side automatic validator?

  
How can i disable the validator on forms?

Thanks in advance,
Hi Bruno,

To disable client side validation on forms you should set Validate Inputs to False in the Buttons of your page.

Cheers,
Tiago Simões
I've done that, in all buttons, but the format validations still remain active.

Check the oml attached please.

Contains only an input associated to an integer var.
Try to type a text, and see the result :(.

Thks
Hi,

In that case wouldn't you use a text variable? Can you explain what do you need to accomplish?

Thank you very much,
Tiago Simões
Hi,

yes, you're right. But the client where this needs to be implemented, because of web designing reasons, don’t want the "integer expected" messages and so on in front of inputs.
They want all validations made in the server side. At last it's not practical the usage a different variable to store data parallel to the record, that needs to de filled persisted and passed to the record for saves.

I just need to disable all javascript validator, and not only the "mandatory validator".

How can I acomplish that?

I' have one solution that it's not praticle either, is to define a custom validator for each input that is diferent than text.

Thks
Hi,

Ok, got it :).

Version 4.0 which will be released soon will feature improved inputs validation both on server and client side.

For now, the only workaround I can think of would be to put this on eSpace javascript.

OsCustomValidatorInteger = function(){ return true;};


Hope this helps,
Tiago