[UPS connector] Dependancy link is invalid?

[UPS connector] Dependancy link is invalid?

  
Forge Component
(0)
Published on 2016-01-14 by Gonçalo Borrêga
0 votes
Published on 2016-01-14 by Gonçalo Borrêga

Trying to install the UPS Connector app but the following link to Geo is broken or invalid.  Please advise?

https://www.outsystems.com/forge/component/439/geo-final/