[Facebook Login Plugin] Warning "App in development mode"

[Facebook Login Plugin] Warning "App in development mode"

  
Forge Component
(2)
Published on 2017-04-18 by Grazina
2 votes
Published on 2017-04-18 by Grazina

I could not make the plugin work!


- At developers.facebook.com:

I created API

I copied ID and SecretKey

API mode public ON

Email contact set

Package and Class Name configured

Generate Hash using

"keytool -genkey -alias {alias} -keystore {name} .keystore | openssl sha1 -binary | openssl base64"

to use in native platforms


- In sample FacebookLoginPlugin

Set - SiteProperties

clientId with App ID

clientSecret with Secret Key


- Native Platforms

Build type debug

app identifier: default name (com.outsystemscloud. {myname} .FacebookLoginPlugin)

config keystore file, alias and alias password.


The warning "Application not configured ... development mode ..." continues to appear.


Where is it missing to configure / set something wrong?

I've tried downloading the original sample, and it's not working either.

Hi

2 things to try:

First make your facebook app public. go App Review > Make <your app> public? turn yes. To be able to do this you need to have a Contact email configured on Settings > Basic

Second you need to add you app ID and name to the Extensibility Configurations of FacebookLoginPlugin. For this go to espace properties.

Regards,

Marcelo

Hi Marcelo,


The first point was correct!

The second, I did not know the property, it was defined, but it did not solve.


Regards

Hi,

I didn't understand what you did on step 2. You still getting the same error?

Regards,

Marcelo

Marcelo Ferreira wrote:

Hi,

I didn't understand what you did on step 2. You still getting the same error?

Regards,

Marcelo

Yes!


Solution

Hi,

Since the site properties aren't working. Did you change this code for you values?

{
    "plugin":
        {
            "url": "https://github.com/OutSystemsExperts/cordova-plugin-facebook4#OS.0.11.0",
            "variables": [{
                "name": "APP_ID",
                "value": "< your app_id>"
            },{
                "name": "APP_NAME",
                "value": "< your app_name>"
            }]
        }
}

This code is on Extensibility Configurations.

Regards,

Marcelo

Solution

It worked, I do not know where I was wrong, but this "Extensibility Settings" setting I did not find in the documentation! I repeated all the steps and it worked the login.

About KeyStore I used the following separate commands:

  1. "keytool -exportcert -v -keystore <nameapp> .keystore -alias <nameapp> -keyalg RSA -keysize 2048 -validity 10000> <nameapp> .bin"
  2. "openssl sha1 -binary <nameapp> .bin> <nameapp> sha1.bin"
  3. "openssl base64 -in <nameapp> sha1.bin -out <nameapp> base64.txt"
  • Sending the generated keystore in Native Platforms.
  • Using the base64.txt file, to configure the Hash Key


Sincere greetings, thanks for the help Marcelo.


Maurilio