CommonUnifiedLogin eSpace reference missing in CommonUnifiedLoginSample eSpace

CommonUnifiedLogin eSpace reference missing in CommonUnifiedLoginSample eSpace

(A) OutSystems Hub Server
Windows 2000 Server SP4 / SQL Server 2000 on laptop 1
(B) OutSystems Service Studio version
Windows XP Professional SP2 Version 2002 on laptop 2
(C) OutSystems Integration Studio version
Windows XP Professional SP2 Version 2002 on laptop 2

Installation procedure
(1) Generic_Samples\UnifiedLogin\HTTPRequestHandler.xif
1-Click Publish OK

(2) Generic_Samples\UnifiedLogin\CommonUnifiedLogin.oml
1-Click Publish OK

(3) Generic_Samples\UnifiedLogin\CommonUnifiedLoginSample.oml
1-Click Publish fails:
Missing Dependency
Could not find the 'CommonUnifiedLogin' eSpace in this server. Application runtime errors might occur.

File ---> Add/Remove References
=== CommonUnifiedLogin is missing in '<hubserver_onlaptop1_name>' ===
=== Uncheck all elements to remove the reference from your espace ===

In Service Studio I can delete the CommonUnifiedLogin eSpace reference and then add the CommonUnifiedLogin reference again but then I have to solve a lot of error messages manually.

In Service Studio the CommonUnifiedLoginSample eSpace reference is missing.
In Service Center I can see that CommonUnifiedLogin eSpace has been correctly deployed to the hub server and is working correctly (no cross next to the eSpace in the Service Center eSpaces list).

Does anyone have similar experiences migrating the CommonUnifiedLogin sample developed for OutSystems version 3 to OutSystems version 4. Is this a known issue?

Thank you in advance for any possible advice. Best regards, Erik Martens

Are you using the exact same files from the sample ?
I have tried this and it worked on a OutSystems Platform 4.0.

From the errors you have sent, I would say that CommonUnifiedLoginSample.oml is referencing a clone of CommonUnifiedLogin.oml with the same name.
eSpaces have a unique identifier to manage references between them, and making a clone on an eSpace referenced by another breaks the referencing. So it is alright to clone consumer eSpaces but if you clone a producer eSpace you will need to update all references in Service Studio.

Tiago Simoes

Thank you for your feedback.

I have successfully installed the Common Unified Login Sample on laptop 1 running OutSystems Hub Server 4.

At this moment I have a development user account on . This development user account does not detect that the HTTPRequestHandler extension is installed on .

I have documented my Common Unified Login Sample installation experiences for your information (see attachment).

Best regards, Erik Martens